Configurazione CISCO per ADSL Alice Business

Il mese scorso ho dovuto configurare delle ADSL di telecomitalia che ci sono state fornite “naked” ovvero senza router. Fortuna che ho recuperato in giro qualche cisco 800 abbandonato (come spesso accade) in precedenti installazioni :-/ …password recovery e via.

Non ho una grande esperienza sui cisco percui ho certcato online una configurazione pronta per il classico contratto Alice Business in cui ti assegnano 8 ip statici, ma nulla. Riporto la configurazione funzionante, magaria a qualcuno può far comodo.

Gli ip pubblici assegnati erano: 85.40.101.240-247. Il punto-punto: 88.55.9.226.
La lan è una 192.168.1.0/24 nattata sul primo ip pubblico.

!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname inter-adsl
!
enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
!
no aaa new-model
ip subnet-zero
no ip source-route
ip domain name inter.it
ip name-server 151.99.125.1
no ip dhcp conflict logging
ip dhcp excluded-address 192.168.1.1 192.168.1.99
!
ip dhcp pool inter
   network 192.168.1.0 255.255.255.0
   domain-name inter.it
   dns-server 151.99.125.1 
   default-router 192.168.1.1 
!
!
ip audit notify log
ip audit po max-events 100
no ftp-server write-enable
!
!
! 
!
!
!
!
interface Ethernet0
 ip address 85.40.101.241 255.255.255.248 secondary
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 no keepalive
 hold-queue 100 out
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface ATM0.1 point-to-point
 ip address 88.55.9.226 255.255.255.252
 ip nat outside
 pvc 8/35 
  oam-pvc manage
  oam retry 5 5 1
  encapsulation aal5snap
 !
!
interface FastEthernet1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet2
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet3
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet4
 no ip address
 duplex auto
 speed auto
!
ip nat pool inter 85.40.101.241 85.40.101.241 netmask 255.255.255.248
ip nat inside source list 50 pool inter overload
ip classless
ip route 0.0.0.0 0.0.0.0 ATM0.1
no ip http server
no ip http secure-server
!
access-list 50 permit 192.168.1.0 0.0.0.255
snmp-server community public RO
snmp-server enable traps tty
!
line con 0
 exec-timeout 240 0
 password inter
 login
 no modem enable
line aux 0
line vty 0 4
 exec-timeout 240 0
 password inter
 login
 length 0
!
scheduler max-task-time 5000
!
end

BTW, per quel che riguarda i punto-punto ho scoperto che se sono terminati (lato centrale) su apparati cisco ti configurano una rete /30 (netmask 255.255.255.252) e fin quì nessun problema. Se invece ci sono apparati diversi usano una fake classe C che sul router vanno impostate appunto come /24 (netmask 255.255.255.0); da notare che sulla scheda di attivazione la netmask impostata in questo caso era 255.255.255.255.

Quindi l’interfaccia ATM risulterebbe:

interface ATM0.1 point-to-point

ip address 88.55.41.63 255.255.255.0

11 thoughts on “Configurazione CISCO per ADSL Alice Business

  1. Ottimo, lo stavo proprio cercando un esempio tipo questo…

    …e se lato ethernet invece che fare nat volessi mettere un server linux o un pc windows che esce (ed entra) con un ip degli 8 assegnati basterebbe impostare la rete come, ad esempio, ip 85.40.101.242 255.255.255.248 e gateway 85.40.101.241?

  2. esatto.

    questo è proprio l’uso per cui è pensata la linea con 8 ip (di cui di fatto ne puoi utilizzare 5).

  3. Ottimo… proverò questa settimana a fare una configurazione nuova sull’857W. Dopo 1 settimana di prove sono riuscito a farlo funzionare facendogli fare NAT ma esco con l’IP della punto-punto… vorrei riuscire a utilizzare gli IP che mi hanno dato in modo da poter mettere online un microsito su un serverino linux sfruttando appunto uno degli IP… se riesco posto la configurazione.

    Grazie ancora per la cortese risposta ;)

  4. Ciao a tutti.
    Anche io ho un router Cisco series 800 da configurare: fino adesso sono riuscito “solo” ad uscire con il punto punto.
    Adesso avrei la necessità di far uscire un server, dietro al router, con uno degli 8 IP assegnati in modo da renderlo visibile – con l’IP esterno – anche da dentro la lan dietro il router (adesso i client della stessa LAN vi possono accedere solo dall’interno …. spero di essermi spiegato … ?? !! :) )
    Non so se devo cambiare tutta la configurazione e fare in modo di non uscire più con il point-to-point oppure se ci sono altri modi…..

    allego configurazione attuale:

    Current configuration:

    !
    version 12.1
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Router
    !
    enable secret 5 XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
    !
    !
    !
    !
    !
    ip subnet-zero
    ip name-server 151.99.125.2
    !
    !
    !
    !
    interface Loopback0
     ip address 85.37.104.100 255.255.255.248
     no ip directed-broadcast
     ip nat outside
    !
    interface Ethernet0
     ip address 192.168.68.254 255.255.255.0
     no ip directed-broadcast
     ip nat inside
    !
    interface ATM0
     no ip address
     no ip directed-broadcast
     ip nat outside
     no atm ilmi-keepalive
     bundle-enable
     hold-queue 224 in
    !
    interface ATM0.1 point-to-point
     ip address 85.37.250.2 255.255.255.252
     no ip directed-broadcast
     ip nat outside
     pvc 8/35
      oam-pvc manage
      encapsulation aal5snap
     !
    !
    interface Dialer0
     no ip address
     no ip directed-broadcast
     no cdp enable
    !
    ip nat inside source list 1 interface ATM0.1 overload
    ip nat inside source static udp 192.168.68.1 1194 85.37.250.2 1194 extendable
    ip nat inside source static 192.168.68.1 85.37.250.2 extendable
    ip classless
    ip route 0.0.0.0 0.0.0.0 ATM0.1
    ip http server
    !
    access-list 1 permit 192.168.68.0 0.0.0.255
    !
    line con 0
     transport input none
     stopbits 1
    line vty 0 4
     password xxxxx
     login
    !
    scheduler max-task-time 5000
    

    Ciao

    Grazie in anticipo :)

  5. salve a tutti voi esperti di reti
    volevo sapere se è possibile usare con alice businnes un router wifi diverso da quello dato da telecom. volevo usare un d-link…

    si può?

  6. LUIGI: ma sei sicuro che esci con l’ip di punto-punto? a parte che teoricamente telecom non te lo dovrebbe lasciar fare, il 85.37.250.2 che hai impostato è il “network address” della tua netmask… se riesco faccio delle prove…

    CARLETTO: per alice “business” la risposta ovviamente è si. Eventualmente il problema è capire come configurare il router visto che su alcuni modelli per semplificare l’interfaccia utente non è possibile inserire tutti i parametri necessari.

  7. Fabio, purtroppo anche io sono nella medesima situazione, esco con l’IP della punto-punto…
    Adesso sto provando a riconfigurare un 837 di recupero e quanto prima farò delle prove con la tua configurazione come base…
    Ti posto uno stralcio della configurazione attuale, il router è un Cisco 857
    interface ATM0
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip route-cache flow
    no atm ilmi-keepalive
    dsl operating-mode auto
    !
    interface ATM0.1 point-to-point
    description $FW_OUTSIDE$
    bandwidth 2048
    ip address 88.xxx.xxx.10 255.255.255.252
    ip access-group 101 in
    ip verify unicast reverse-path
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip inspect SDM_LOW out
    ip nat outside
    ip virtual-reassembly
    pvc 8/35
    oam-pvc manage
    oam retry 5 5 1
    encapsulation aal5snap
    !
    !
    interface Vlan1
    description $FW_INSIDE$
    ip address 192.168.1.1 255.255.255.0
    ip access-group 100 in
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat inside
    ip virtual-reassembly
    ip route-cache flow
    hold-queue 100 out
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 ATM0.1
    !
    ip nat inside source list 2 interface ATM0.1 overload
    !
    access-list 1 permit 192.168.1.0 0.0.0.255
    access-list 1 deny any
    access-list 2 permit 192.168.1.0 0.0.0.255
    access-list 100 deny ip 88.xxx.xxx.8 0.0.0.3 any
    access-list 100 deny ip host 255.255.255.255 any
    access-list 100 deny ip 127.0.0.0 0.255.255.255 any
    access-list 100 permit ip any any
    access-list 101 permit icmp any host 88.xxx.xxx.10 echo-reply
    access-list 101 permit icmp any host 88.xxx.xxx.10 time-exceeded
    access-list 101 permit icmp any host 88.xxx.xxx.10 unreachable
    access-list 101 deny ip 10.0.0.0 0.255.255.255 any
    access-list 101 deny ip 172.16.0.0 0.15.255.255 any
    access-list 101 deny ip 192.168.0.0 0.0.255.255 any
    access-list 101 deny ip 127.0.0.0 0.255.255.255 any
    access-list 101 deny ip host 255.255.255.255 any
    access-list 101 deny ip host 0.0.0.0 any
    access-list 101 deny ip any any log
    access-list 102 permit ip 192.168.1.0 0.0.0.255 any
    access-list 102 deny ip any any

    Con questa conf metto gateway 192.168.1.1 ed esco con l’ip della punto punto… e due anni fa dopo 3gg di prove è stato l’unico sistema che ho trovato per farlo andare…

  8. raga a me nn funge con la 7mb di alice il router 857W sto cercando di registrarmi sul sito ma è casino…

  9. Devo purtroppo riconfigurare con urgenza un Cisco 2600, che pensavo fosse in gestione a Telecom (lo era la scheda contenuta nel router venduto ed installato da loro ma non il router … incredibile!!!).

    La classe d’indirizzi pubblici è 217.x.x.1-8
    punto-punto 80.x.x.0-4
    la rete interna 180.x.x.x.
    Ho un firewall che rileva le chiamate sull’Ip pubblico e reinstrada le stesse sull’ip interno
    Per gli ip 217.x.x.3 e 217.x.x.4 voglio rendere disponibile l’accesso tramite terminal server.

    Sarei grato se qualcuno potesse darmi indicazioni.

    Attualmente la configurazione, che non funziona, è

    ————————
    version 12.0
    service timestamps debug uptime
    service timestamps log uptime
    !
    hostname xxxxxxxxx
    !
    enable secret .x
    enable password x
    !
    !
    !
    !
    !
    ip subnet-zero
    !
    !
    !
    !
    interface Ethernet0/0
    ip address 217.x.x.2 255.255.255.248
    no ip directed-broadcast
    !
    interface Serial0/0
    no ip address
    no ip directed-broadcast
    shutdown
    !
    interface Serial0/1
    description point to point
    bandwidth 1024
    ip address 80.x.x.3 255.255.255.252
    ip access-group 103 out
    no ip directed-broadcast
    ip nat outside
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Serial0/1
    ip route 217.x.x.0 255.255.255.0 Serial0/1
    no ip http server
    !
    access-list 103 permit ip 217.x.x.0 0.0.0.255 any
    !
    line con 0
    transport input none
    line aux 0
    line vty 0 4
    login
    !
    no scheduler allocate
    end

    ———————

  10. Ho fatto una VPN “site to site” tra 2 alice adsl business, per farlo ho dovuto usare gli indirizzi punto-punto.
    Sicuramente c’è un modo per usare gli indirizzi della LAN publica. Qualcuno mi può aiutare?
    I router sono dei Cisco 857.
    Grazie.

  11. Salve a tutti,

    ho un problema con 2 alice hiperway che fanno da punto-punto in 2 sedi diverse ed 1 alice business nella prima delle sedi che dovrebbe far navigare su internet entrambe le sedi. La punto-punto funziona e le 2 reti si pingano senza problemi, non riesco però a far andare su internet i pc che stanno nella seconda sede (Lan classe 9, ovvero 192.168.9.x], mentre quelli che sono nella stessa rete della alice business navigano senza problemi [Lan classe 10, 192.168.10.x, il router che va su internet Alice business ha indirizzo 192.168.10.10 mentre il secondo router che comunica con l'altra hiperway ha il 192.168.10.99].

    Non ho un router cisco e non so come fare per dire ai miei router (zyxel 600HW] di utilizzare il GW dell’alice business per uscire verso l’esterno, ovvero quel che sui router cisco si può indicare impostando la route:

    ip route 0.0.0.0 0.0.0.0 192.168.10.10 (nel mio caso questo è il gw che vorrei far utilizzare ai pc che si trovano nella classe 192.68.9.x ovvero la sede remota). In questo router non mi accetta l’indirizzo 0.0.0.0 nelle routes statiche e non so quindi come fare per dirottare tutto il traffico proveniente dalla 192.168.9.x sul router 192.168.10.10]

    Qualcuno mi saprebbe dire come fare? Grazie mille, Luca

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>